GLIBCXX_3.4.20 not found
log in

Advanced search

Message boards : Linux : GLIBCXX_3.4.20 not found

Author Message
mmonnin
Send message
Joined: 28 Nov 16
Posts: 19
Credit: 5,313,490
RAC: 0
Message 131 - Posted: 19 Jun 2017, 0:32:49 UTC
Last modified: 19 Jun 2017, 0:33:48 UTC

http://xansons4cod.com/xansons4cod/result.php?resultid=924886

My 1st several Linux MT tasks all failed with this error:

<stderr_txt> ../../projects/xansons4cod.com_xansons4cod/xansons_boinc_OMP_1.0: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ../../projects/xansons4cod.com_xansons4cod/xansons_boinc_OMP_1.0) </stderr_txt>


I found this Ubuntu solution for it:
https://askubuntu.com/questions/575505/glibcxx-3-4-20-not-found-how-to-fix-this-error

Running this said I already had the latest version:

sudo apt-get install libstdc++6


So I added the repository per the link and reran.

sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install libstdc++6


It installed an update. Got some more units after the update and they are completing successfully.

Vlad
Project administrator
Project developer
Project tester
Project scientist
Help desk expert
Send message
Joined: 26 Oct 16
Posts: 321
Credit: 103,382
RAC: 0
Message 135 - Posted: 19 Jun 2017, 8:09:11 UTC - in response to Message 131.


It installed an update. Got some more units after the update and they are completing successfully.

Thank you! I updated the system requirements and added a link to this thread.

Profile [B@P] Daniel
Send message
Joined: 18 Jun 17
Posts: 25
Credit: 47,963,162
RAC: 0
Message 141 - Posted: 19 Jun 2017, 11:18:05 UTC - in response to Message 135.


It installed an update. Got some more units after the update and they are completing successfully.

Thank you! I updated the system requirements and added a link to this thread.

Better way would be to link glibc and libstdc++ statically. Older systems may not have new package ready, and user would be forced to compile new glibc and gcc to get them.
____________

Profile Conan
Send message
Joined: 11 Nov 16
Posts: 1
Credit: 79,898
RAC: 0
Message 218 - Posted: 23 Jun 2017, 4:57:58 UTC

Was wondering why one of my computers was not getting any points on this project, and found that it is producing nothing but errors.

Complains that /lib64/libc.so.6 GLIBC_2.17 was required and apparently I did not have it.

After doing some checking and trying to update a few things it seems that my Linux version of Fedora (number 16) is now too long in the tooth for this project and so I have stopped it trying to get work.

It has very little trouble with most projects so I will use it on them instead.

Too big a hassle to try and update Fedora as there has been 9 versions released since and another one due soon.

Conan

Vlad
Project administrator
Project developer
Project tester
Project scientist
Help desk expert
Send message
Joined: 26 Oct 16
Posts: 321
Credit: 103,382
RAC: 0
Message 219 - Posted: 23 Jun 2017, 7:56:49 UTC - in response to Message 218.
Last modified: 23 Jun 2017, 7:57:52 UTC

Complains that /lib64/libc.so.6 GLIBC_2.17 was required and apparently I did not have it.

Starting with the version 1.01 the OpenMP and OpenCL apps for linux are built with -static-libgcc -static-libstdc++. The oldest linux kernel they were tested on is 3.10. Thanks to your report now we know they fail on the kernel 3.6.
I updated the System Requirements. Now they say that the kernel 3.10 and above is required. However, I set the minimal supported kernel version in the linux plan class specifications to 3.7 (it was 3.0 previously) to determine the oldest kernel version the apps work on.

Message boards : Linux : GLIBCXX_3.4.20 not found


Main page · Your account · Message boards


© 2020 Vladislav Neverov (NRC 'Kurchatov institute'), Nikolay Khrapov (Institute for Information Transmission Problems of RAS)